Juni

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Juni app login is not available
Resolved·Full outage

A fix has been implemented and the incident related to Juni app login is not available has been fully resolved.

Wed, Apr 22, 2026, 06:47 PM
(1 month ago)
·
Affected components
Apr 22, 2026, 06:43 PM
06:47 PM
Updates

Resolved

A fix has been implemented and the incident related to Juni app login is not available has been fully resolved.

Wed, Apr 22, 2026, 06:47 PM

Investigating

We have identified that Juni app login is not available right now. We're working on to get it resolved.

Wed, Apr 22, 2026, 06:43 PM