Monitoring
We are seeing regular traffic and our provider is recovering. Services are back to normal and we are monitoring the situation.
Identified
We are monitoring an outage that effects our provider and in turn effect card authorizations of Juni cards