Resolved
A fix has been released to resolved the delay in transfers being displayed in the Transactions View
Investigating
We have identified an incident related to a delay in transfers being displayed in the Transactions View that is impacting a limited number of customers. During this time, please refrain from retrying transfers you've successfully initiated to avoid duplicate payments to recipients. We apologize for any inconvenience caused - rest assured we are working to resolve this as a priority.