Invoices aren't marked as paid
Resolved

We think the impact from the issue is over.

Tue, Oct 8, 2024, 05:00 PM
(9 months ago)
·
Affected components

No components marked as affected

Updates

Resolved

We think the impact from the issue is over.

Tue, Oct 8, 2024, 05:00 PM

Investigating

We have identified an incident related to paid invoices that is impacting a limited number of customers. We apologize for any inconvenience caused - rest assured we are working to resolve this as a priority.

Tue, Oct 8, 2024, 04:18 PM(41 minutes earlier)