Problems loading the dashboard
Resolved

This incident has been resolved.

Thu, May 18, 2023, 01:22 PM
(2 years ago)
·
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Thu, May 18, 2023, 01:22 PM

Monitoring

The problem has been identified and fixed, we will keep monitoring the system.

Thu, May 18, 2023, 12:15 PM(1 hour earlier)

Identified

We are having problems with displaying the dashboard for some customers, because of an issue with exchange rates. We have identified the issue and we are fixing it now.

Thu, May 18, 2023, 12:10 PM