Issues with invoice payments to recipients in HK / CN
Resolved·Partial outage

A fix has been implemented and the incident related to <<product name/feature as per Status Page sections>> has been fully resolved.

Thu, Jul 3, 2025, 04:11 PM
(6 days ago)
·
Affected components
Updates

Resolved

A fix has been implemented and the incident related to <<product name/feature as per Status Page sections>> has been fully resolved.

Thu, Jul 3, 2025, 04:11 PM

Identified

Some customers are experiencing issues when trying to transfer money to CN / HK.

Wed, Jul 2, 2025, 12:32 PM(1 day earlier)