Delays with incoming payments to the SE IBANs
Resolved·Degraded performance

Incoming payments to SE IBAN’s should now be processing normally.

Sat, Aug 30, 2025, 09:41 AM
(3 days ago)
·
Affected components
Updates

Resolved

Incoming payments to SE IBAN’s should now be processing normally.

Sat, Aug 30, 2025, 09:41 AM

Monitoring

We are currently experiencing delays with incoming payments to the SE IBANs.

Thu, Aug 28, 2025, 02:14 PM(1 day earlier)

Investigating

We are currently experiencing issues with incoming transfers to SE IBANs from Citibank, PayPal, and Swedbank. We apologise for any inconvenience caused. Our team is actively investigating and working to resolve the problem.

Wed, Aug 27, 2025, 10:01 AM(1 day earlier)