Issues with Incoming Transfers
Resolved·Partial outage

Provider update:
We have now cleared the backlog of transactions. This incident has been fully resolved and there is no impact on clients accounts.

See partner reporting for more details

Wed, Sep 3, 2025, 02:00 PM
(1 week ago)
·
Affected components
Updates

Resolved

Provider update:
We have now cleared the backlog of transactions. This incident has been fully resolved and there is no impact on clients accounts.

See partner reporting for more details

Wed, Sep 3, 2025, 02:00 PM

Investigating

We have identified an incident related to receiving incoming transfers that is impacting all customers. We apologize for any inconvenience caused - rest assured we are working to resolve this as a priority.

Wed, Sep 3, 2025, 12:05 PM(1 hour earlier)