Third party outage is affecting direct topups from Nordea
Resolved·Degraded performance

The incident related to topup from Nordea has been fully resolved.

Wed, Nov 12, 2025, 12:17 PM
(1 week ago)
·
Affected components
Updates

Resolved

The incident related to topup from Nordea has been fully resolved.

Wed, Nov 12, 2025, 12:17 PM

Investigating

We apologize for any inconvenience caused - rest assured we are working with our payment partner to resolve this as a priority.

Wed, Nov 12, 2025, 11:07 AM(1 hour earlier)