Service Disruption: Card Payments & Management
Resolved·Full outage

The incident has been fully resolved.

Thu, Jan 22, 2026, 11:54 PM
(6 days ago)
·
Affected components
Updates

Resolved

The incident has been fully resolved.

Thu, Jan 22, 2026, 11:54 PM

Monitoring

Our card processing provider have deployed a fix to resolve the incident. We are monitoring the situation but can see that most of the services are back.

Thu, Jan 22, 2026, 07:48 PM(4 hours earlier)

Monitoring

We are currently experiencing a service disruption affecting card payments, 3D Secure (3DS) verification, and card management features.
Impact:

  • Payments: Card transactions may fail or be declined.

  • Verification: You may be unable to complete 3DS checks for online purchases.

  • Card Details: Viewing sensitive card information (such as CVV or PAN) is currently unavailable.

This issue is caused by a confirmed outage with our card processing partner. They have identified the root cause and are working to restore services. We are monitoring their progress and will provide updates as soon as systems stabilize.

Thu, Jan 22, 2026, 06:46 PM(1 hour earlier)