Juni platform disturbance
Resolved·Degraded performance

A fix has been implemented and the incident related to the Juni Platform has been fully resolved.

Tue, Feb 17, 2026, 02:02 PM
(1 day ago)
·
Affected components
Updates

Resolved

A fix has been implemented and the incident related to the Juni Platform has been fully resolved.

Tue, Feb 17, 2026, 02:02 PM

Monitoring

We have deployed a fix to resolve the incident related to the disturbance in Juni platform. Services are back to normal and we are monitoring the situation.

Tue, Feb 17, 2026, 12:58 PM(1 hour earlier)

Investigating

We have identified an incident related to Juni platform, that is impacting a limited number of customers. We apologize for any inconvenience caused - rest assured we are working to resolve this as a priority.

Tue, Feb 17, 2026, 12:36 PM(22 minutes earlier)