EUR cards and accounts: Technical difficulties with partner banks
Incident Report for Juni
Resolved
Incident is now marked as resolved due to restructuring of components on status page, further information and updates on the incident will be posted later.
Posted Apr 29, 2022 - 12:24 CEST
Update
We are now enabling all verified customers to use the new EUR accounts.
There are currently some temporary limitations on account usage. Outbound payments cannot be made from EUR accounts and EUR accounts can only receive funds from your external registered business account or payment gateway. EUR cards can be used as normal for transactions.
To access your new EUR account, please login to the Juni portal and verify your company details.
Posted Apr 18, 2022 - 10:23 CEST
Update
We are now enabling all verified customers to use the new EUR accounts.
There are currently some temporary limitations on account usage. Outbound payments cannot be made from EUR accounts and EUR accounts can only receive funds from your external registered business account or payment gateway. EUR cards can be used as normal for transactions.
To access your new EUR account, please login to the Juni portal and verify your company details.
Posted Apr 12, 2022 - 17:07 CEST
Update
We have now finished the last adjustments and invited all our EUR customers to verify their company details in our portal. This is to ensure access to our new EUR accounts and cards. We have also started to enable verified customers so they can start using them. We're here to help - please do not hesitate to reach out to us on our support bot or email support@juni.co.
Posted Apr 01, 2022 - 15:24 CEST
Update
We are now making the last adjustments to change partner banks for EUR cards and accounts later this week, and we will now begin to invite existing customers and verify their company details as soon as possible. This is to ensure our customers are set up and ready to go when we launch our new EUR accounts and cards.
Posted Mar 29, 2022 - 18:36 CEST
Update
We are now making the last adjustments to change partner banks for EUR cards and accounts later this week, and we will now begin to invite existing customers and verify their company details as soon as possible. This is to ensure our customers are set up and ready to go when we launch our new EUR accounts and cards.
Posted Mar 28, 2022 - 16:13 CEST
Update
We still have ongoing issues with our partner banks for EUR cards and accounts. The issues of the last few days have led to us to change EUR provider as soon as possible, and we're hoping to have that process completed early next week. We will come back to you soon with further information and an update on how we’re solving any outstanding issues.
Posted Mar 25, 2022 - 15:27 CET
Update
We’ve now extended the transfer window for our customers to be able to transfer their funds to an external account. Please login to the Juni portal for more information on how to proceed.
Posted Mar 24, 2022 - 14:01 CET
Update
After initial problems for some customers with transfer of funds from EUR accounts, it is now working as intended. Please log into the Juni portal and follow the updated instructions on what you can do today to access your funds.
Posted Mar 24, 2022 - 10:19 CET
Update
We now have a solution ready for most of our customers to be able to transfer funds from EUR accounts. Please log into the Juni portal and follow the instructions on what you can do today to access your funds.
Posted Mar 23, 2022 - 17:23 CET
Update
We are now preparing a solution for our customers to be able to access funds. More information is sent to affected customers.
Posted Mar 23, 2022 - 11:53 CET
Identified
We are experiencing technical difficulties with our partner banks for EUR cards, both for send money and receive money. We are urgently working to resolve this issue and will share an update ASAP. Apologies for the inconvenience caused. GBP cards and transfers are not affected.

Rest assured, the funds in your Juni account are safeguarded in our segregated accounts with the Bank of Lithuania and the Bank of England. We will ensure you will get access to these funds as soon as possible and are working urgently to resolve these issues. Apologies for the inconvenience caused.
Posted Mar 22, 2022 - 16:23 CET
Update
Right now we are experiencing issues with our partner banks for EUR cards. Send money and receive money are affected and are not processing at the moment. We’ll update the status as soon as we get more information. We are continuing to investigate this issue.
Posted Mar 22, 2022 - 13:19 CET
Investigating
We are currently investigating this issue.
Posted Mar 22, 2022 - 12:51 CET