Issue with paying invoices
Incident Report for Juni
Resolved
The impact from the issue is over.
Posted Oct 25, 2024 - 16:08 CEST
Monitoring
We have deployed a fix to resolve the incident. We are monitoring the situation.
Posted Oct 25, 2024 - 14:50 CEST
Identified
We have found the issue and are working on a fix.
Posted Oct 25, 2024 - 14:08 CEST
Update
It appears many customers are still able to pay invoices; this issue is only affecting some customers, but we're still actively diagnosing and remediating.
Posted Oct 25, 2024 - 10:16 CEST
Investigating
We have identified an incident related to paying invoices that is impacting any customers who pay invoices via Juni. We apologize for any inconvenience caused - rest assured we are working to resolve this as an immediate priority.
Posted Oct 25, 2024 - 10:09 CEST