No components marked as affected
Resolved
This incident has been resolved.
Monitoring
A fix has been implemented and we are monitoring the results.
Identified
Web Application can now be accessed through https://app.juni.co.
Investigating
We are continuing to investigate this issue.
Investigating
We are currently investigating this issue.