Delays in GBP send money & receive money
Incident Report for Juni
Resolved
This incident has been resolved.
Posted Oct 15, 2022 - 09:12 CEST
Monitoring
We are currently seeing a slight delay in customers sending and receiving money into and from their GBP accounts. All other bank transfers and currencies are functioning as normal and card payments are not affected.
If you are experiencing any delays please do not hesitate to reach out to us on our support bot or email support@juni.co.
Posted Oct 14, 2022 - 20:05 CEST
This incident affected: Web Application (Transactions).