Invoices aren't marked as paid
Incident Report for Juni
Resolved
We think the impact from the issue is over.
Posted Oct 08, 2024 - 19:00 CEST
Investigating
We have identified an incident related to paid invoices that is impacting a limited number of customers. We apologize for any inconvenience caused - rest assured we are working to resolve this as a priority.
Posted Oct 08, 2024 - 18:18 CEST