The role of buyers can't currently see their assigned cards.
Incident Report for Juni
Resolved
This incident has been resolved.
Posted Apr 12, 2022 - 17:07 CEST
Identified
The role of Buyers can't currently see their assigned cards. Admins can still access all cards. We are working on releasing an fix.
Posted Apr 12, 2022 - 15:57 CEST