Duplicated June card transactions
Incident Report for Juni
Resolved
We have processed all card transaction refunds and refunded incurred fees.
Posted Nov 20, 2024 - 14:17 CET
Update
We have processed refunds for most transactions and are looking into processing the remaining ones.
Posted Nov 19, 2024 - 11:10 CET
Update
We are continuing to work on a fix for this issue.
Posted Nov 18, 2024 - 17:16 CET
Identified
We are aware of an ongoing incident with our card provider. As a result, some customers may see additional transactions on their account. We are working with our provider to remediate the problem and perform corrective refunds. This does not affect future transactions.
Posted Nov 18, 2024 - 17:01 CET