Problems loading the dashboard
Incident Report for Juni
Resolved
This incident has been resolved.
Posted May 18, 2023 - 15:22 CEST
Monitoring
The problem has been identified and fixed, we will keep monitoring the system.
Posted May 18, 2023 - 14:15 CEST
Identified
We are having problems with displaying the dashboard for some customers, because of an issue with exchange rates. We have identified the issue and we are fixing it now.
Posted May 18, 2023 - 14:10 CEST